Service Pack for ProLiant (SPP) Version 2019.03.0

HPE has released latest version of server hardware firmware as HPE Service Pack for ProLiant (SPP). This is first release for 2019 and it contains all firmware for hardware which still supported by HPE. There is no new firmware for discontinued devices.

Release Summary of Service Pack for ProLiant (SPP) Version 2019.03.0

The 2019.03.0 SPP Production release contains components supporting the ProLiant, Synergy and Apollo Gen9 and Gen10 server platforms and options.

The 2019.03.0 SPP Production release provides support for:

  • Smart Update Manager 8.4.0
  • Online updates for Gen9 servers running VMware ESXi 6.7 U1  
  • Red Hat Enterprise Linux 7.6
  • SUSE Linux Enterprise Server 12 SP4

This SPP 2019.03.0 release supersedes the SPP 2018.11.0. 

Resolved Customer Advisories (CAs)

The below issues has been fixed in this release:

Date CA Number Description Fixed SPP Version
2/15/2019 a00065356 (Revision) HPE OneView – OneView Will Fail to Upgrade iLO 5 Automatic Server Recovery (ASR) Driver on Windows Server with Agentless Management Service 1.30.0.0(B) 2019.03.0
1/22/2019 a00064663 Linux – Flash Engine on all Drive Smart Components for Linux Modify File Permission of an Embedded storcli RPM and any Subsequent RPM Verification on Drive Smart Component RPM will Fail and Block Smart Update Manager (SUM) 2019.03.0
1/21/2019 a00064443 Red Hat Enterprise Linux 7.5 – HPE Gigabit Ethernet Adapters Are Unable to Receive Packets when Maximum Transmission Unit (MTU) is higher than 1500 with HPE Intel IGB Driver Version 5.3.5.19 2019.03.0
12/21/2018 a00062579 HPE Ethernet 10/25Gb 2-port 622FLR-SFP28 Converged Network Adapter – Firmware 8.35.43 Enables Additional Storage Functionality and Prevents Downgrades to Earlier Firmware Versions 2019.03.0
12/12/2018 a00061900 HPE Ethernet Adapters – Intel E1R Driver for Windows Version 12.14.8.0 Download Does Not Include an Associated Compsig File for HPE Integrated Lights-Out (iLO) Repository Support 2019.03.0
10/18/2018 a00058528 (Revision) HPE Network Adapters – On HPE ProLiant Servers Running Any Linux Operating System and Configured With Certain Network Adapters With Firmware and Boot Code Version 7.13.63 (Or Later), Jumbo Packets May Fail 2019.03.0

There is an open issue which be fixed in the future release but firmware is available to download:

DateCA NumberDescriptionFixed SPP Version
3/19/2019a00066514HPE Hard Disk Drives – FIRMWARE UPGRADE REQUIRED For Certain HPE 7.2K (2TB/1TB) SATA Hard Disk Drives to Prevent a Potential Data Integrity RiskFuture Release

Unknown Issues/Limitations

There is some unknown issues or limitations that you should consider those issues, here is the list of them:

DateCA NumberDescription
11/2/2018a00059710HPE Network Adapters – Unsupported VMware Mellanox Firmware Smart Components Get Selected For Deployment On ProLiant Gen10 Servers With VMware ESXi 6.0/6.5 and Configured With Certain Network Adapters During Remote Online Deployment Using SUM
9/18/2018a00036618(Revision) Linux – Both the Mellanox OFED or Mellanox Ethernet + RoCE driver and the Broadcom / QLogic RoCE Ethernet Drivers Will Not Load on an HPE ProLiant System
7/12/2018a00051588HPE ProLiant Gen7 Servers – On Systems Running VMware vSphere 6.0 And Configured With Certain Network Adapters, The HPE QLogic NC382i/NC532x Online Firmware Upgrade Utility for VMware Version 1.15.1 Displays as Selected at Every SUM Launch
11/6/2017a00030192HPE Network Adapters – Mellanox Ethernet + RoCE And OFED Driver Installation Conflicts With Broadcom NetXtreme-E Driver On HPE ProLiant Servers Running SUSE Linux Enterprise Server 12 SP3 (Or Later) And Configured With Certain Network Adapters
7/29/2017a00020829HPE OneView – OneView Reports “The Firmware Bundle Information Is Unavailable” When Uploading the Service Pack for ProLiant 2017.07.1 (or Later)

Compatibility with Older SPP

Updating from one SPP to another is suitable when the SPP versions are within 12 months of each other. This means, if the newer SPP was released within 12 months of the currently installed SPP’s release date, skipping intermediate releases is appropriate.

Update is supported from 2018.11.0  2018.09.0,  2018.06.0 to 2019.03.0. So older firmware should update to at least 2018.06.0.

Important Note

Certain HPE Intel Based Ethernet Networks Adapters May Experience a Random TCP Receive (Rx) Packet Data Pointer Issue When Using The “Jumbo Packet” Feature With “Receive Side Coalescing (RSC). As a workaround, disable the “Jumbo Packet” from the Windows Device Manager in the [Advanced] tab for all HPE Intel based Ethernet 700 Series Network Adapters. HPE has released a Customer Bulletin that describes this issue in more detail.

References

http://h17007.www1.hpe.com/us/en/enterprise/servers/products/service_pack/spp/index.aspx

Further Reading

HPE Management Component Pack (MCP)

Red Hat Enterprise Linux 8.0 Beta

NFTables, The Next Generation of Packet Classification Framework

External Links

Download Service Pack for ProLiant 2019.03.0

SPP Documentation

Service Pack for ProLiant (SPP) Version 2019.03.0 –Release Notes

Service Pack for ProLiant (SPP) Version 2019.03.0 – Component

Service Pack for ProLiant (SPP) Version 2019.03.0 –Release Notes

Service Pack for ProLiant (SPP) Version 2019.03.0 –Contents Report

Service Pack for ProLiant (SPP) Version 2019.03.0 –Server Support Guide

Davoud Teimouri

Davoud Teimouri is as a professional blogger, vExpert 2015/2016/2017/2018/2019, VCA, MCITP. This blog is started with simple posts and now, it has large following readers.

1 Response

  1. My Name says:

    Can’t access the download = 404

Leave a Reply

Your email address will not be published. Required fields are marked *

Subscribe to our newsletter and join other subscribers

Holler Box