EIGRP over Frame-Relay

EIGRP over Frame-Relay

EIGRP over Frame-Relay

In this project we have three sites and they are connected together by a frame-relay environment and also we want to run EIGRP on our routers.

After configuration, each client should be able to ping others.

Our clients configuration are as follows:

{C1}

IP Address: 192.168.1.2/30

{C2}

IP Address: 192.168.2.2/30

{C3}

IP Address: 192.168.3.2/30

In this step we’ll configure a router as a frame relay switch:

{Interface Serial 1/0}

FR(config)#frame-relay switching
FR(config)#int s1/0
FR(config-if)#no ip add
FR(config-if)#no shut
FR(config-if)#encapsulation frame-relay
FR(config-if)#clock rate 64000
FR(config-if)#frame-relay intf-type dce
FR(config-if)#frame-relay route 102 interface s1/1 201
FR(config-if)#frame-relay route 103 interface s1/2 301

 

{Interface Serial 1/1}

FR(config)#int s1/1
FR(config-if)#no ip add
FR(config-if)#no shut
FR(config-if)#encapsulation frame-relay
FR(config-if)#clockrate 64000
FR(config-if)#frame-relay intf-type dce
FR(config-if)#frame-relay route 201 interface s1/0 102

{Interface Serial 1/2}

FR(config-if)#int s1/2
FR(config-if)#no ip add
FR(config-if)#no shut
FR(config-if)#encapsulation frame-relay
FR(config-if)#clockrate 64000
FR(config-if)#frame-relay intf-type dce
FR(config-if)#frame-relay route 301 interface s1/0 103

In the next step, we’ll configure interfaces on other routers:

{CSite}

CSite(config)#int f2/0
CSite(config-if)#no shut
CSite(config-if)#ip add 192.168.1.1 255.255.255.252
CSite(config)#int s1/0
CSite(config-if)#no shut
CSite(config-if)#encapsulation frame-relay
CSite(config)#int serial 1/0.1 point-to-point
CSite(config-subif)#ip add 10.0.0.1 255.255.255.252
CSite(config-subif)#frame-relay interface-dlci 102
CSite(config)#int serial 1/0.2 point-to-point
CSite(config-subif)#ip add 20.0.0.1 255.255.255.252
CSite(config-subif)#frame-relay interface-dlci 103

{Site2}

Site2(config)#int f2/0
Site2(config-if)#no shut
Site2(config-if)#ip add 192.168.2.1 255.255.255.252
Site2(config)#int s1/0
Site2(config-if)#ip add 10.0.0.2 255.255.255.252
Site2(config-if)#no shut
Site2(config-if)#encapsulation frame-relay

{Site 3}

Site3(config)#int f2/0
Site3(config-if)#no shut
Site3(config-if)#ip add 192.168.3.1 255.255.255.252
Site3(config)#int s1/0
Site3(config-if)#ip add 20.0.0.2 255.255.255.252
Site3(config-if)#no shut
Site3(config-if)#encapsulation frame-relay

Next step, configure EIGRP on CSite, Site2 and Site3:

{CSite}

CSite(config)#router eigrp 1
CSite(config-router)#network 192.168.1.1 0.0.0.3
CSite(config-router)#network 10.0.0.1 0.0.0.3
CSite(config-router)#network 20.0.0.1 0.0.0.3

{Site2}

Site2(config)#router eigrp 1
Site2(config-router)#network 192.168.2.1 0.0.0.3
Site2(config-router)#network 10.0.0.2 0.0.0.3

{Site3}

Site3(config)#router eigrp 1
Site3(config-router)#network 192.168.3.1 0.0.0.3
Site3(config-router)#network 20.0.0.2 0.0.0.3

In final step, Site1 and Site2 must be defined as “Stub” and also because multicast packets will be dropped by frame relay, we must add neighbors manually:

{CSite}

CSite(config-router)#neighbor 10.0.0.2 Serial 1/0.1
CSite(config-router)#neighbor 20.0.0.2 Serial 1/0.2

{Site 2}

Site2(config-router)#neighbor 10.0.0.1 Serial 1/0
Site2(config-router)#eigrp stub

{Site3}

Site3(config-router)#neighbor 20.0.0.1 Serial 1/0
Site3(config-router)#eigrp stub

you can download project file from here.

Good luck.

 [quotes_and_tips]

 

Davoud Teimouri

Davoud Teimouri is as a professional blogger, vExpert 2015/2016/2017/2018/2019, VCA, MCITP. This blog is started with simple posts and now, it has large following readers.

Leave a Reply

Your email address will not be published. Required fields are marked *

Subscribe to our newsletter and join other subscribers

Holler Box